Pulse config error "No TM1 instances were found in API"


#1

Hi there,

We need a little help troubleshooting Pulse configuration here.

Pulse was installed on a testing evironement yesterday (with some issues: it would crash when clicking on “Download the .NET Framework” button, so we got it and installed it separately and re-run the install, mentionning it, just in case it might be related).

The wizard set-up was run properly. Live Monitoring works fine.
When going in “Administration>Instance Settings”, selecting the TM1 instance and trying to set-up the Login/Password to connect Pulse to the instance to generate the documentation, we get this error message: “No TM1 instances were found in API”.
Saving it anyway and trying to generate the documentation for the selected instance gives the same message in Status column “Unable to document system: No TM1 instances were found in API”.

The path to the bin folder is properly set-up when checking “BinDirectory” parameter in Pulse.cfg file.
Instance has IntegratedSecurityMode=2 (when running the wizard, it asked for CAM settings)
Pulse Version: 5.7.10
TM1 Version: 10.2.20700
OS: Windows Server 2012 R2 Standard

Any idea of what we could try?

Cheers


#2

Hi @Celine,

If Pulse is configured to the Bin64 folder correctly, The next thing to check is the account used to execute the services, can you try using the the same account used by the tm1 services?

Regards,

Erik


#3

Hi @Celine,

The following post should list all reasons why Pulse would not be able to run the documentation:

Cheers,

Vincent


#4

Hi @Celine,

Perhaps you would like to look at point 7 of Vincent’s post. We had a couple of issues before with the TM1JavaApi.jar.

Regards,

Erik


#5

Hi @ecarmona,

Thanks for the idea, just checked, and the logs show the copy worked fine:

2018-10-31 03:14:49.8508 Info JarCopier TM1JavaApi.jar copied from D:\Program Files\ibm\cognos\tm1_64\bin64…\bin\classes\TM1JavaApi.jar

Even though, I did it again manually, just to be sure… but we still get the same error message.

@Vincent, I checked all the other bulletpoints, and everything seems fine.
I’m logued to Architect using the login/password specified in the config file, it’s not using CAM, I can see the instance in Pulse, after the instance’s restart, I can properly see the “}src_xx” processes.

Any other idea?

Cheers,
Celine


#6

Hi Everyone,

After The TM1JavaAPI.jar seems the cause of the problem, but we were not able to find a TM1 installation with the same version of TM1 to replace it manually. We activated the CAPI and the documentation and change tracking problems were solved.

Regards,

Erik