Widget Type Text-box - Unable to add text?

Hello Exports,

I’ve created a Text-box widget but cannot seem to be able to find how to add text! Can someone please point me in the right direction?

Thanks,
David

You need to make the Read Only property of the text box widget false. This property is true by default.

Thanks for your reply @cw-ch, it looks like we need to upgrade our UX. We are seeing different menu options for the text box. With our version (2021.21.11 FP2) ready only doesn’t default to Yes but it still won’t allow us to edit.

Thanks,
David

Of course it is always a good idea to upgrade however write access for text box does still work perfectly in your version. Even without having the advanced options dialog to write the code for you you can still just sdd the following to the advanced options for the widget.

"textBox": {
    "readOnly": false
}

Hi @cw-ch,

We have updated UX to the latest version, however, we are still seeing the same issue with text-box where we are unable to edit, even after adding the advance options. Could there be an issue with our content store?

Thanks,
David

Hi David,

Content Store should not be relevant here.

For the text box widget to work all dimensions for the cube being referenced must be either global fixed or global filter. You can’t put and dimensons on rows, columns or widget filter.

If you still have issues I suggest you contact your local cubewise office.