Why no Spreader?


#1

I have a table, where I want long text strings to be truncated, but all visible when selected. I don’t want it to wrap and make the cell higher.

Using the style overflow: hidden; works for me, however doing this also hides the spread/reference/comment dropdown.

On top of this I’m not getting the spread option anyway in the dropdown if it isn’t hidden.

the dbr is

                                    <tm1-ui-dbr
                                        tm1-instance="dev"
                                        tm1-cube="Volumes Effort"
                                        tm1-elements="{{global.$stateParams.costing}},{{global.$stateParams.version}},{{row['Row ID'].name}},Data Entry,{{cell.dataset.headers[2].columns[$index].name}},{{cell.dataset.headers[0].columns[$index].name}},{{cell.dataset.headers[1].columns[$index].name}}"
                                        tm1-hide-reference="false"
                                        tm1-hide-comment="false"
                                        tm1-hide-spread="false"
                                        tm1-hide-drill="false"
                                        tm1-hide-context-menu="false"
                                        ng-model="cell.dbrValue"
                                        tm1-multi-line="2"
                                        >
                                    </tm1-ui-dbr>

#2

Hi @mmacdonnell,

Can you post in here a sample screenshot of how it looks like and also how are you applying the styles.

Also, what do you mean by the spread option being hidden in the dropdown if it is hidden? Does that mean the rest of the options are showing? Could you post a screenshot of this as well?

Thanks!


Paul


#3

You can see the top of the dropdown in the bottom of the cell
The style is:
.wide-column {
white-space: nowrap;
max-width: 400px;
overflow: hidden;
}

And with overflow: hidden; removed from the style


#4

Hi @mmacdonnell,

Thanks for the screenshots!

So about the hidden dropdown, search for the element through CSS selectors and try give it a high z-index property.

As for the no spreader, that is because Canvas only shows that for Numeric and Consolidated cells. Is there any particular reason or action why you would want a spread on a text cell?


Paul


#5

Hi Paul,

i’ll have a look into z-index.

The cell is N. it is not text.

Thanks
Mal


#6

Hi @mmacdonnell,

Oh okay! Is that a consolidated element or a leaf level element? Because it will only show it for a cell that is both Numeric and Consolidated only.

And the other thing is, I noticed that you were using multi-line even for numeric inputs. Just for reference, you can also put a style/class into input elements.

Cheers!

Paul


#7

So it only does the proportional spread on consolidated items?


#8

Hi @mmacdonnell,

That is just related on the “Spread” context menu at consolidated cells.

On the Leaf level cells, you can use “r”, like typing “r > 100” to propagate 100 to the cells on the right, provided that the cells are within an HTML table.

Which spreading action are you looking into? Other than the above, you will have to contact your Cubewise local office to submit an enhancement request. We will then have a look and assess on it.


Paul


#9

Thanks Paul,

I’ll have a play with that.

Cheers
Mal