Use Pulse to create your technical documentation


#1

I’m sure that most of you have already used Pulse to create the Flow Diagram. But did you know that you can also use Pulse to create your technical documentation.

With the technical documentation, you will be able to see the relationships between your TM1 objects, as well as information about views and subsets to give you a full picture of what the model contains.

You can then add your own commentary to each object providing context for what the system is used for.

How to add your commentary in the technical documentation:

From the Pulse web client, there is a description field that you can update for all your TM1 objects such as

Cubes:

Dimensions:

Chores and Processes:

Once all descriptions have been updated, you can then see them in the technical documentation (Reports > Documentation > Technical Documentation), choose what you want to include:

and then click the generate button to create the documentation:

Migrate documentation from one Pulse server to another:

You don’t need to maintain the documentation in all your instances, you can use the Pulse migration feature to migrate the documentation from one instance to another:

Disable footers and headers on large model:

For a very large model, if your techical documentation has more than 1000 pages, you might need to disable headers and footers:

By having an up to date documentation, you will make on boarding of new developers a much easier process, you will no longer have a single point of dependency with all of the knowledge in one person’s head.


#2

Hi @Vincent. Technical documentation does not work for me. We get an error ‘unable to generate report:Authentication Required’.

Under the instance the documentation is setup and works. I can generate the flowchart PDF but not the technical documentation.

Brian


#3

Hi @bknott,

Are you using Pulse with Windows Authentication (WindowsAuthentication = true in Pulse.cfg)?

In Pulse v5.7.3, the Technical Documentation does not work if you run it with a user using Windows Authentication.

If you change WindowsAuthentication = false in Pulse.cfg and restart Pulse services, the Technical Documentation should work.

We have a ticket already for this issue, we will let you know when we have a fix.

Cheers,

Vincent


#4

Yep @vincent we are using windows authentication. Happy to leave it at the moment.

Brian