Setting up SSO

Having some trouble getting SSO working. Below is the error message:

PAWDev is where UX is installed. Content store is called Apliqo_demo, and it along with the TM1 models are on server called PADev. This seems like more of a CAM/BI security issue, just can’t seem to get past it.

The Canvas posts/guides are useful to a point, but I can’t be certain when something applies to UX and Canvas.

Hope someone can help? Thanks in advance.

Disable Cognos Application Firewall in Cognos Configuration, or add the URL of the server in the same place as an exception.

Have done so (various iterations of the URL). I’ve got:
image
When I turn off the firewall I get a different error:

You need to add URL to variables_tm1.xml in exactly the same way as configuring SSO for tm1web.

Thanks for replying.

Got that too:

image

Hi @mhaynes,

Two things:

  1. The URL that you will need to configure must match the URL on how you will access the application. I would guess that you are trying to access the ApliqoUX via localhost? Looking at the screenshot, on the parameter c_cmd, of the url, will help on here as well.

  2. You will most probably need to have the parameter in the instances.json -> useSSORedirecWithBaseURL and set it to true. What it will do is to always send the same URL to Cognos BI for validation. On this case, it will always just send the base URL of your Apliqo application to Cognos BI. This URL, as you will see with the parameter c_cmd, must be the same exact URL that you will configure in your variables_TM1.xml

Reference: https://code.cubewise.com/canvas-docs/parameters-in-the-instancesjson-file

Let us know how it goes.


Paul

Hi Paul and Jack

Thanks, I was able to resolve the issue - two things:

  1. yes, localhost would not pass the firewall, but using the full URL name would
  2. I am connecting to multpile tm1 servers and the camNameSpace parameters needs to be specified for each (and not just the content store)

Thanks for the help!