Rendering issue with DBR cells


#1

I’ve just installed v1.2.1 for the client and I’m getting a weird rendering of the DBR function.

As you can see on screenshot error 1, the sample salary entry template appears that the editable DBR is showing a picklist option whereas the Payment method is no longer showing it. Also the read-only DBR cells are not properly rendering the numbers to thousand separators and rounded to whole dollars.

On error 2, this is showing a modal screen where we have editable DBR cells in the bottom 2 rows. The DBR formulae are referencing string cells but yet there is a picklist arrow showing and the cell also doesn’t allow me to type into it.

I’m not having any of the above issues on my own laptop. On the client’s machine, I have tried using IE and Chrome (updated to latest version), and the both exhibit the same behaviour as shown in the screenshots.

Is there a reason why this is happening?


#2

Hi @Sb5,

Have you tried clearing the cache?

  1. Bring up Chrome Developer Tools by clicking F12
  2. Go to the Network tab
  3. Check “Disable Cache”
  4. Refresh the page with F5

Does that fix the problem?


#3

Hi Tim

Yes I have. I generally have Disable Cache on when I’m testing.

I have just double checked and the DBR is still being rendered the same as the uploaded screenshots.


#4

Hi Ben,

Is this an upgrade or a fresh install? Can you also post the version of TM1.


#5

Hi @Sb5,

From the looks of the error screenshot, the name of the Employees is not appearing. Had seen this normally with Fix Pack 4. The feature to get the alias information on a subset was introduced on the REST API with Fix Pack 5 at least.

The modal that you are seeing might have been dependent on the names of the employees’ alias but was not able to do so because it was unable to retrieve the alias in the first place.


Paul


#6

Hi Tim

This was a fresh install. The client never had Canvas installed.

Their TM1 version is 10.2.20200.55 which i assume is FP2?

So from Paul’s post it seems the issue is because their TM1 is not up-to-date?


#7

Hi Ben,

That is correct, as a minimum we support FP5 but it is recommended to be on the latest as there have been lots of improvements to the REST API in recent versions.


#8

Thanks Tim and Paul!

Issue resolved after upgrading to FP7.