Reasons why Pulse will not log a Excel workbook


#1

Extend vs Excel Logger

Pulse uses an Excel add-ins to monitor how Excel is used by TM1 users. Starting with Pulse v5.6, you can choose between two Excel add-ins. We recommend using the new Excel Logger instead of Extend. Excel Logger is a lighter version which will work better for Excel 2016 64 bits than Extend. If you just need the logging feature, you should use now Excel Logger. Excel Logger is the new Excel Add-ins for Pulse moving forward.

Please find below all the reasons why Pulse would not be able to log Excel workbooks:

1. Check if Extend or Excel logger is setup properly

It is very quick to set up Extend or the Excel Logger, just follow these steps:

2. Check if the Excel Logging box is ticked in Pulse

Login to Pulse as Admin, go to Administration > Configuration and check if the TM1 Workbooks box is ticked:
image

3. By default Pulse logs only TM1 enabled workbook

The Extend or Excel Logger toolbar communicates back to the Pulse server each time a user creates, saves, opens or closes a TM1 enabled Excel workbook. A TM1 enabled workbook is one that contains at least one of the following formulas: TM1RPTVIEW, VIEW, DBRW, DBR or DBS. If the Excel add-ins can’t find a TM1 formula, it will not log the workbook.

4. Search by default on the first 50 rows and 50 columns

The Excel Add-ins search for TM1 formulas only on the first 50 rows and 50 columns of each tab. If the TM1 formulas are after these rows and columns, the workbook won’t be logged.
These settings can be found in the cwxtndxl.ini file located in C:\Users\username\AppData\Roaming\CWExtend

DETECT_SHEET_RANGE_ROW=50
DETECT_SHEET_RANGE_COLUMN=50

5. Check ‘TM1_LOG_MAX’ property

In the same cwxtndxl.ini file, ensure that TM1_LOG_MAX is a value that is not zero (i.g. 30). This denotes the time interval that these Excel information gets sent to Pulse.
If TM1_LOG_MAX=0, the Excel addins will not send any data to Pulse.

6. Check the logs

After these steps, if the Pulse workbook logging is still not working, you can find more information in the logs (ErrorLog.txt). The Excel addins logs can be found in the following folder:

  • C:\Users\username\AppData\Roaming\CWExtend

It can be noted that Extend and the new Excel Logger uses the same user profile folder (AppData\Roaming\CWExtend). This has been done to help the transition from Extend to Excel Logger. If you want to replace Extend with Excel Logger, you just need to replace the add-in in Excel and then Excel Logger will use your previous settings defined in AppData\Roaming\CWExtend.

7. Save the Excel file after slicing a view

Pulse will log an Excel Workbook only if it the Excel file is saved somewhere, when you create a slice from a cube view, you will have to save the Excel file first for Pulse to pick it up.


#2

Hello
I checked the steps above and everything is set correct but when i try and slice a cube view nothing is logged. The error message i receive in the ErrorLog.txt is the following: 2019-01-28 19:11:18 MFormatApply ApplySliceFormats 0.

I am using 64 bit excel and TM1 version 10.3 and Pulse version 5.8.

I also receive an error each time i open excel which i have included. I click no, TM1 loads and i see that the excel logger add in is active.

Any ideas why it’s not logging?

Thanks


#3

Hi @nfrigo,

Is this a new installation? Or was it working previously?

Can you try to right click on it, click Properties, and check for a check box in there that has a label “Unblock”? If you have it, un-check that and try to open your Excel again?

Also, can you check the log file for the Extend Logger if there is any?


Paul

Reference: https://social.technet.microsoft.com/Forums/office/en-US/4a15e472-a265-4058-b439-7d79c2670817/xls-file-will-not-open-in-excel-2016-only-gray-view?forum=excel


#4

Hi @plim
New installation. Do you mean right click on the excel logger.xll file? I don’t see any check box with a label “Unblock”. I am attaching the only log files in my roaming CWExtend folder. Let me know if there is somewhere else I should look for logs.

I tried just using the logger but it required modifying a file cwxtndxl.ini, which i did not have because i had not installed extend so I installed extend and then followed the instructions for setting up logger but it is not logging.

Let me know if you need any other info.
Thanks

ConveyLog.txt (285 Bytes)

ErrorLog.txt (55 Bytes)


#5

Hi @nfrigo,

The Log file is named Excel-Logging.log and should be in CWPulseLogger folder.

Have you added the directory of your Excel Logger (i.e. C:\Excel Logger) into Excel’s Trusted Locations property?


Paul


#6

Hi @plim
I have not added it to trusted locations. I also do not have a CWPulseLogger folder (i saw that there should be one in the roaming folder but I only have CWEXtend) and no exel-logging.log file. I will try adding it to my trusted locations and running it again.

I will let you know the outcome.
Thanks
Nicole


#7

@plim
I added it as a trusted location and restarted excel. Tried to slice a view again…nothing shows in pulse and no new logs or logging folders.


#8

Hi @nfrigo,

Is the prompt when you open up Excel still there?

That would be great if it is not there anymore, as it confirms some Excel security as the root cause.

Next step now is to ensure that the Excel Logger add-in has been activated. It might have been disabled since it was last loaded. So can you check if the Add-in is Active like so:

image

The other thing that you we can do to test is to open up Excel and re-add the Add-In again. That should at least initialize the CWPulseLogger folder.


Paul


#9

Hi @nfrigo,

This is normal, Pulse will log an Excel Workbook only if it the Excel file is saved somewhere, when you create a slice from a cube view, you will have to save the Excel file first for Pulse to pick it up.

As you can see in the screenshot, after saving my slice as “Test-slice.xlsx”, Pulse was able to pick it up:

When testing the Excel tracker, it might be better to open a spreadsheet from the TM1 applications folder as these ones as picked up straightaway.

I hope this help.

Cheers,

Vincent


#10

Hi @nfrigo,

Have you executed documentation for the instance that is hosting these workbooks?

Regards,

Erik


#11

@ecarmona @Vincent

Yes. @plim was nice enough to get on a meeting with me and we debugged it together. I had the incorrect version (32 bit) and something else was happening with excel finding the add-in location. All is working now.
Thanks