Reasons why Pulse will not log a Excel workbook

Hi All,

The content from this post has been moved to this new help article:

Cheers,

Vincent

1 Like

Hello
I checked the steps above and everything is set correct but when i try and slice a cube view nothing is logged. The error message i receive in the ErrorLog.txt is the following: 2019-01-28 19:11:18 MFormatApply ApplySliceFormats 0.

I am using 64 bit excel and TM1 version 10.3 and Pulse version 5.8.

I also receive an error each time i open excel which i have included. I click no, TM1 loads and i see that the excel logger add in is active.

Any ideas why it’s not logging?

Thanks

Hi @nfrigo,

Is this a new installation? Or was it working previously?

Can you try to right click on it, click Properties, and check for a check box in there that has a label “Unblock”? If you have it, un-check that and try to open your Excel again?

Also, can you check the log file for the Extend Logger if there is any?


Paul

Reference: XLS file will not open in Excel 2016, only gray view

Hi @plim
New installation. Do you mean right click on the excel logger.xll file? I don’t see any check box with a label “Unblock”. I am attaching the only log files in my roaming CWExtend folder. Let me know if there is somewhere else I should look for logs.

I tried just using the logger but it required modifying a file cwxtndxl.ini, which i did not have because i had not installed extend so I installed extend and then followed the instructions for setting up logger but it is not logging.

Let me know if you need any other info.
Thanks

ConveyLog.txt (285 Bytes)

ErrorLog.txt (55 Bytes)

Hi @nfrigo,

The Log file is named Excel-Logging.log and should be in CWPulseLogger folder.

Have you added the directory of your Excel Logger (i.e. C:\Excel Logger) into Excel’s Trusted Locations property?


Paul

Hi @plim
I have not added it to trusted locations. I also do not have a CWPulseLogger folder (i saw that there should be one in the roaming folder but I only have CWEXtend) and no exel-logging.log file. I will try adding it to my trusted locations and running it again.

I will let you know the outcome.
Thanks
Nicole

@plim
I added it as a trusted location and restarted excel. Tried to slice a view again…nothing shows in pulse and no new logs or logging folders.

Hi @nfrigo,

Is the prompt when you open up Excel still there?

That would be great if it is not there anymore, as it confirms some Excel security as the root cause.

Next step now is to ensure that the Excel Logger add-in has been activated. It might have been disabled since it was last loaded. So can you check if the Add-in is Active like so:

image

The other thing that you we can do to test is to open up Excel and re-add the Add-In again. That should at least initialize the CWPulseLogger folder.


Paul

Hi @nfrigo,

This is normal, Pulse will log an Excel Workbook only if it the Excel file is saved somewhere, when you create a slice from a cube view, you will have to save the Excel file first for Pulse to pick it up.

As you can see in the screenshot, after saving my slice as “Test-slice.xlsx”, Pulse was able to pick it up:

When testing the Excel tracker, it might be better to open a spreadsheet from the TM1 applications folder as these ones as picked up straightaway.

I hope this help.

Cheers,

Vincent

Hi @nfrigo,

Have you executed documentation for the instance that is hosting these workbooks?

Regards,

Erik

@ecarmona @Vincent

Yes. @plim was nice enough to get on a meeting with me and we debugged it together. I had the incorrect version (32 bit) and something else was happening with excel finding the add-in location. All is working now.
Thanks