Pulse TM1 Web Logging

Hi,

Found a link as below,
http://cloud.apliqo.ch:8099/help

It says there is tm1web.exe for updating the config in tm1 web folder,

And what I installed is “PASS” instead of “TM1 Web” in folder tm1_64, so this is not the outcome I expected,

How could I define the path to update config for PASS?

Thanks.

Hi @vhsieh ,

This PASS setup, is it on the same folder within tm1_64? Or outside of that?

You can override the path it will try to search for, assuming they have the same folder structure, via override of the following parameter:

tm1-bin-path

Enable TM1 Web Logging to Pulse v6.x - Cubewise CODE

Cheers!

Paul

@plim ,

Thanks, tested that way works, PASS folder is outside of tm1.

@plim, I’m trying a similar setup of Pulse 6 tracking of TM1Web and can’t quite get it working.

Environment overview:

  • Box 1: TM1 server
  • Box 2: Pulse
  • Box 3: TM1Web

After I copy “tm1web.exe” to Box 3, I get an error when running it with the -tm1-bin-path parameter.

It appears I am able to overcome this by adding the -tm1-version parameter and the pulse files do get added to the tm1web folder.

Since Box 3 (TM1Web) needs to communicate with Box 2 (Pulse), I assume I would need to open up the necessary ports on either Box 3 or Box 2. Do you have any guidance on which ports to open? To populate the TM1Web usage data, is the Pulse box pulling in data from TM1Web (e.g., open ports on Box 3) or is the TM1Web box pushing to Pulse (e.g., open ports on Box 2)?

For testing, I tried opening all ports on both Box 2 and Box 3 but do not see any data in “User Analytics”. Thanks in advance for any help!

Hi @wwang ,

Though it may not be directly stated, the port that you have passed above is the one that you will need to be opened between Box 2 and 3.

As per document above, has the tm1web been restarted? Try to access Pulse from within Box 3 as well via the pulse-server-name and the pulse-server-port you have passed above:

Cheers!

Paul

@plim, thanks for your recommendations! I am using the default 8099 port so made sure that there are firewall incoming rules to allow it on both Box 2 and Box 3. I am also able to access Pulse through “http://pulseservername:8099” on Box 3.

I also tried restarting the TM1Web Spreadsheet Services but it didn’t seem to help either. Do you have any other ideas on anything I may be missing? Thanks!

Hi @wwang ,

On a more recent ticket, we found out that the name of the Server where tm1web is hosted, is not under one of the Pulse Monitor names created in Pulse.

Can you help check if this might be the case?

As an example, assuming that the TM1/PA servers served by that tm1web in there appears in Pulse under the Pulse Monitor Name SERVER1. Try to search for the following line in the pulseLog.jsp file on your tm1web installation:

String targetURL = String.format("%1$s://%2$s:%3$s/weblog?id=%4$s", protocol, pulseServerAddress, pulsePortNo, id);

And update it to (had added &servername=SERVER1),

String targetURL = String.format("%1$s://%2$s:%3$s/weblog?id=%4$s&servername=SERVER1", protocol, pulseServerAddress, pulsePortNo, id);

If the above still did not resolve it, please help create a ticket and let us continue the investigation from there.

Cheers!

Paul

1 Like