Pulse command line install


#1

In the help.pdf the installation provided is a GUI one. is there a way to install silently by specifying install details via a conf file and just running setup.exe from a commandline/powershell.


#2

Hi @shallabh.khera,

Pulse uses the NSIS installer, it supports a /S command line option to silently install. It isn’t something we recommend as it is being installed on a server and installs should be infrequent. See: http://nsis.sourceforge.net/Docs/Chapter3.html


#3

Thanks @tryan - we are now trying with this option. Thanks.


#4

Hi @tryan we installed using the /S option the Pulse gets installed. But when checking for services only ‘Pulse for TM1’ service is up. ‘Pulse for Application Server’ doesn’t start.PulseTM1AWS.docx (42.4 KB)

Upon checking event logs as well - didn’t receive any information. Do you have any information on if the scripting needs to change? your feedback would be helpful.


#5

I think what is missing is that during the manual install the max memory for the tomcat instance running the pulse application server gets set and the silent install isn’t doing this and therefore the service doesn’t start.


#6

Thanks @cw-ch - I did think that might be the case but I believe 1024 is set by default. I’m not sure.

So if we set straight in the conf folder then the service should start… I’ll try to do that - thanks.


#7

Hi @shallabh.khera,

To set the memory manually you need to edit the Windows registry:


#8

Thanks @tryan. I am able to find the issue in the registry.
Apart from JvMs & JvmMX - also need to set the following -
Start

Mode - REG_SZ - jvm
Stop

Mode - REG_SZ - jvm
& also the
Java

Options doesn’t have the catalina params set.

Once I had set them in registry - it ran :slight_smile: Now would try to do the same via powershell scripts.

Thanks.


#9

I’m now getting this error on auto-install and setting the windoes registry keys

The Pulse for TM1 Application Server service terminated with the following service-specific error:
The system cannot open the file.

Any ideas would be helpful.


#10

Hi @shallabh.khera,

We don’t really support nor have tested the silent install options for Pulse. Attached are the default registry settings required for the Pulse application server.

Let us know if that helps.

pulse-appserver.zip (1.1 KB)


#11

Thanks @tryan it worked :slight_smile:
regedit /s pulse-appserver.reg

Awesome stuff.