Pulse Canvas Logs - Empty User Name

canvas

#1

Hi,

We are logging Canvas use in Pulse, however, sometimes Pulse doesn’t record a user name (see screenshot below). Any ideas why this happens?

Thanks,
David


#2

Hi @anz.fin.all.mailbox,

This situation could be related to the PAL/TM1 version, with which version is installed in your premises?

Regards,

Erik


#3

Hi @ecarmona,

We are on 10.2.2 fix pack 7 (10.2.20704.67).

Thanks,
David


#4

Thanks @anz.fin.all.mailbox!

I will perform some tests and come back to you.

Regards,

Erik


#5

Hi @anz.fin.all.mailbox,

Which IntegratedSecurityMode is set for this TM1 instance?

Regards,

Erik


#6

Hi @anz.fin.all.mailbox,

We have performed several tests in order to replicate your issue in our labs, but we were not able to achieve it. We tested with Pulse 5.8 and Canvas v3.1.0 under a TM1 10.2.2 FP7 installation, with diverse Integrated Security Modes.

Could you please tell us:

A) The version of Pulse
B) The version of Canvas
C) The IntegratedSecurityMode that has been configured in the TM1 instance?

Thanks in advance,

Erik


#7

Hi @ecarmona,

Apologies for the late reply, here is the information you requested:

A) Pulse version 5.7.10
B) Canvas version 2.0.7 (3.1 in dev but yet to migrate to prod)
C) IntegratedSecurityMode = 2

Thanks,
David


#8

Thanks @anz.fin.all.mailbox !

We will look at this internally and come back to you.

CC: @plim

Regards,

Erik


#9

Hi @anz.fin.all.mailbox,

Thanks for the update on the versions!

We did a few more tests and have found symptoms similar to the above. Based on the results of our tests, the above happens whenever a Canvas page does not have an active session and needs to login. Upon logging in, the page will be logged to Pulse but the user information seems like it was not included by Canvas.

Everything else goes back to as per normal once you navigate to another Canvas page.

We will coordinate with your local Cubewise office for further verification and resolution on this matter.

Thanks and Cheers!
Paul