Pulse 5.5.1 Migration -rollback backup

pulse

#1

Error: Unable to upload package: file header not found for given file name, cannot extract file

Under Pulse Configuration, I’ve set up a Backup directory path so before each time I execute a manually created package in the target environment the backup of the pre deployment snapshot takes place. A need arisen when I’ve a deployment failed, and wanted to rollback to previous state by running a package saved(Y:\Program Files\Pulse for TM1\migration_back_up_folder).

When tried to upload the package (zip file) form Import Package Migration feature above error appeared.

When tried again, new error The Package file 2342x.zip already exists. None of these packages are available under Migration > View Packages.

Please assist,
Thanks,
Nainoor Thaker


#2

Hi @nainoor.thaker,

If I understand correctly, you are trying to import in Pulse a Backup zip folder, you can import only packages which have been created by the migration feature. Please find below more explanation:

Before executing a migration package you can choose to Back-up the Data Directory:

What it means is that Pulse is going to run a Save Data on the target TM1 instance and then zip the TM1 data folder. The zip folder will contain all TM1 objects before the migration. You can try to unzip it and you will see all TM1 objects:

If you want to “rollback” to this version, you will have to do it manually:

  1. Copy TM1 objects from back up to target TM1 instance
  2. Restart TM1 instance

In the migration feature, the import button is only to import Migration package:

You cannot import a TM1 data backup folder. The migration package have a specific format:

If you do not want to rollback manually, you can use the Pulse rollback button, you will be able to rollback one TM1 object at a time without restarting the TM1 instance:

I hope this help


#3

Thanks for clarification and supporting article.

best regards, Nainoor