ODBC Connection fails after migration from one instance to another with pulse

I performed a migration from instance “PF” to “Contabilidad” including a TI Process that is using ODBC data source. After migration was completed, I opened the TI on destination instance(Contabilidad) but the preview data failed…

All ODBC’s are available for all instances but I think there’s something wrong with credentials…
The ODBC’s were set with service account (the account that’s running tm1 service) credentials.

When I am executing the migration from PF to Contabilidad, Pulse ask me for ODBC credentials and show me my own credetencial as default:

So, as the ODBC doesn’t work with my personal credentials I remove the user and password before executing the migration package:

And finally when I open the TI on destination instance it returns this error on preview data:

Could you please help me to clarify what’s happening and how can I solve this issue?

Hi @jjramirez,

Have you tried manually updating the TI process’ credentials part?

How was the TI process originally setup with the service account? To clarify, was it originally created / setup by not providing a username and credential information?

Are you able to manually fix the issue? What were the steps that you have done?



Hi @plim,

I can´t manually update the credentials beacuase I don’t have access to that password. Admin Server originally set the ODBC to use the service account credentials. I just have to select the ODBC and leave in blank the user and password and it works pretty well on instance “PF”


  1. create a package from instance “PF” including the TI.
  2. execute the migration package on instance “Contabilidad”
  3. As Pulse show the odbc connection with my own credetencial(as you can see in picture attached), I cleaned user/password fields because ODBC is not working with my credentials.
  4. After complete the migration I just open the TI on instance “Contabilidad” and the preview fails.

Thanks for your answers!

Hi @jjramirez ,

It would be interesting to see if you get the same error when creating a new process manually in the target instance.

Could you please try to create a new process in the target instance Contabilidad, enter the data source information, and click the preview button to see if you get the same error?



Hi @Vincent

I was trying that yesterday and got the same error when creating new process in Contabilidad. It looks like credentials are diferent for each instances… I am consulting to the adminserver to confirm… in case yes, the problem wouldn’t be the pulse migration package.