Instance names not loading for IBM Cloud

Hi all,

We have a IBM PA Cloud client who is attempting to trial Arc but we run into the following issue. On launching the Arc.exe, the instance names do not load but the loading spinner continues to spin.

image

Looking at the arc.exe window, it appears the sessions added appear to get removed.

This only appears to be an issue when running Arc on the client company laptop (not an issue when accessing from non-company laptop) so the “settings.yml” should be correct. Any ideas on what could be blocking Arc or how to check?

Thanks!
Wei

Hi @wwang,

It could be a firewall or proxy settings that are required in a corporate environment. Arc needs to connect to the remote server so that might be blocked.

You should start with 1 connection and get that working first. You can get extra logging details by changing the logging level in the settings.yml file to DEBUG:

# The level of logging to display in th Arc console and log file
# Options: CRITICAL, ERROR, WARNING, NOTICE, INFO, DEBUG
# CRITICAL shows the least information and DEBUG the most
loggerlevel: INFO

Hi Tim,

Thanks for the tip on the DEBUG logging setting! It appears there is nothing unusual on the log except that after the “Opening URL: http://localhost:7070” line, the “Session added” line does not appear.

The issue is definitely related to something specific related to their corporate laptops. Are there any specific ports that need to be opened when running Arc from an individual machine? The user machine can access the PA Cloud url from a web browser, but I suppose something on their corporate side is blocking the API request to the same url.

Any suggested workarounds or just have them try on a non-corporate machine? Thanks!

Hi @wwang,

There are no ports to open but all outbound internet traffic may have to go through a proxy in a corporate environment.

In the Windows command line you can set the proxy and then run Arc like this:

SET HTTP_PROXY="http://proxyIp:proxyPort"
arc.exe

You can also set HTTP_PROXY in your environment variables: