HTML Files Not Updating/Committing


#1

I am unable to update my html files and they seem to be caching on the tomcat server. No matter what I do to the source html file my canvas applications are not updating. I have deleted my browser’s cache, cookies, etc. I get the same issue in incognito mode as well. I Tried deleting the localhost cache under work/Catalina/localhost and even tried deleting the original html file and the old file STILL loads into the browser. I tried restarting the canvas application service and this does not fix the issue. This leads me to believe the file is being cached somewhere and I cannot find where. I tried searching through the canvas application folder structure for some sort of cache but could not find any. Perhaps the file is being cached in memory? I have had this happen on multiple instances of Canvas and seems to happen randomly. I have even had it where I will refresh and my new html will commit then I will refresh again then an older version of my html will be loaded, one that does not even exist in the file structure of the server Canvas is being hosted on.

You can see here the html being pulled into the browser is not the same as what I currently have saved on the server

You can see by the get header that the document is not cached by the browser and is indeed getting this file from the server. This does not make sense because this is not the contents of this html file on the server.


#2

Hi @tyler_salminen I often will open the site in another browser like chrome or firefox, just to confirm that its not the browser that is caching. This will at least narrow down is the issue is client or server side.

Brian


#3

Hi Tyler,

There is no real magic in Tomcat and we don’t cache the HTML files on the server. Tick the “Disable Cache” box (at the top) on the Network tab in Chrome Developer Tools and try again. The other possibility is that you have the incorrect path in the browser address.


#4

Thank you tryan I will try out disable cache


#5

Hi guys,

I have exactly the same problem as Tyler. When I update an HTML page, it is not refreshed on the browser (Chrome, IE or Firefox).
I tried the @tryan 's solution. It works, but … I must tick the “Disable Cache” option and let open the inspector bar (F12), otherwise the page is not refreshed.

Someone would have a permanent tip?

Thanks in advance.

Cheers,
Bill


#6

Hi,

In chrome, the solution is leaving the inspector bar open.
But in firefox, you can configure the browser not to cache. Here is how to do:
https://support.mozilla.org/en-US/questions/905902


#7

Hi @monder,

Thanks a lot.
It works well :wink: