Hiding X Axis Label on tm1-ui-chart-dbr

chart
canvas

#1

Hi all,

How do I hide this part of the labels?

Checked documentation, and play around tm1-label, tm1-label-hidden, none of them work, I tried the following:

  1. not put anything, data label turns to DXX.
  2. put tm1-label = “”, only show the first data point.
  3. put tm1-label={{month}} tm1-label-hidden=true, only show the first data point
  4. not put tm1-label, but put tm1-label-hidden=true, only show the first data point

But since the chart is really small and intended to show on mobile, so we need to save as much space as possible,

Thanks


#2

Hi @twong,

The correct attribute name should be tm1-hide-label. And it should be written as tm1-hide-label="true"
Though this is only applicable to specific charts only.

If the above attribute does not work, the other way to go about it is through the tm1-options-override. And this is the applicable options:

tm1-options-override="{chart:{showXAxis: false}}"

Or if you want to hide the Y axis values as well:

tm1-options-override="{chart:{showXAxis: false, showYAxis: false}}"

Here are other articles you can look at that is helpful too:

Cheers!
Paul