GET API Request Locking Other Processes

We have a thread in Pulse that is related to a GET API request and this is running very long from an unknown source, causing locks in the processing of other threads. We have tried to determine the source of this request (as Pulse is stating the thread is initiated from an ARC session), but when closing all the ARC sessions of all the users, the request continue to process.

We have also tried the following to stop this thread from processing (without any success):

  • Tried to kill the thread in Pulse, without success;
  • Tried to kill the process in ARC, without success;
  • Tried to disconnect the user in both Pulse and ARC, without success;
  • Closed all the different ARC sessions for all users and administrators (hoping this might kill the thread), without any success;
  • Closed all the Chrome operations in the server manager of all users connected to the server, without any success;
  • Stopped ARC as a service on all the environments (to see whether this kills the thread), without any success.

Any idea how to determine from where this thread is being executed and how we can kill it?

Pulse and Arc leverage the TM1 REST API to initiate thread cancellations or user disconnections. However, it is ultimately TM1 that determines whether a thread can be successfully canceled. Keep in mind that certain threads may be non-cancelable.

1 Like