"Expand Above" Subsets Not Showing Correctly in UX

Hello Experts,

We’ve just noticed that subsets we are using in views or grid widgets are no longer showing correctly if they’re set to “Expand Above”. Specifically, the +/- button is always showing + even if the consol is expanded. Both the Perspectives and Arc subset editors are showing correctly with the - icon, however.

The screenshots below are from the same subset, the first one is how it is displayed in UX and the second in Arc:

We’re sure UX used to display correctly but have only just noticed this change. Any suggestions?


Try to reset the subset in the subset editor make sure the expand above is enabled and save the dimension changes again

Hi @ishapiro,

I tried your suggestion but still no change. Any other tips? Is anyone else seeing the same behaviour?


Screenshot 2023-07-28 224043

Seems to work for me , enable the expandAbove on a set save as subset , save the changes after closing the subset editor and the cubeview setup modal

I think the issue the OP is having is that they are using a subset which isn’t defined as expand above in the subset itself but they want to use expand above just in UX.

Create a duplicate Subset that is defined as expandAbove or use the MDX that derives the subset and add in the ApliqoUX as type of MDX not Subset

Hi @ishapiro @cw-ch,

Thanks for your replies. The subset was defined as expand above, it just wasn’t showing that way in UX, even after redefining the subset.

What fixed it was going into the subset editor in UX in the view definition and toggling “Expand Above” off and on again (as per @ishapiro first screenshot). I had to do this in every view that uses these subsets so it seems like it was a glitch in the UX views themselves rather than the subset.

All ok now.


An alternative would be to use MDX with an “Expand Mode” placeholder

{TM1ToggleExpandMode({ {TM1FILTERBYLEVEL( {TM1DRILLDOWNMEMBER({[DEM SKU].[DEM SKU].[$<<SOP.DEM SKU.DEM SKU>>]}, ALL, RECURSIVE)}, $<<Level>>)} },EXPAND_$<<Expand Mode>>)}

This is a good tip. For complex cases I often use a helper dimension with the MDX to apply stored as an attribute. The text of the attribute value can itself contain UX setting service placeholder variables.

Then the MDX for the rows which you enter in the advenced settings would just look like

1 Like