Elements does not match the cube’s dimension countnull


#1

I have set up a TM1 model ,
and when trying to retrieve data from TM1 via Canvas ,
I always get the following error :
“Elements does not match the cube’s dimension countnull”

the cell exist in this cube , and all the right dimensions are mentioned
( I tried with other cubes as well and get the same error message )

TM1 version is : 11.1.00000.30

attached is the error message , the code , and the rest api log file for that request.

what could be the reason ?

@sschreurs

error message 1request 1

rest log.txt (10.7 KB)


#2

@tganz

Do you have more than 1 dbr on that page?

Queries are batched up, you can see them in the console network tab as “batch” entries. That error may relate to a different DBR in a batch, and not the one you reference.

Jack


#3

Nope , just 1 single DBR ,
Nothing else…


#4

@tganz

Can you post the contents of your HTML file?

Jack


#5
test

Tomer Ganz
Apliqo Product Manager

[cid:image001.png@01D1F950.5A6148C0]

Cubewise Switzerland
IBM Business Analytics Partner

Level 4, Witikonerstrasse 15, 8032 Zurich, Switzerland
t. +41 44 552 05 85 | m. +972 52 3773550 | skype Tomer.ganz
e. tganz@cubewise.commailto:tganz@cubewise.com | w. www.cubewise.comhttp://www.cubewise.com/

Global Business Partner of the Year, IBM Business Analytics


#6

Hi @tganz,

Although the dimension shown on the Cube Viewer is 6, from the TM1 response as attached in the rest.log.txt file, there were actually 7 dimensions being returned.

Try this one out from the browser:

GET /api/v1/Cubes('FIN Currency xR')/Dimensions?$select=Name

The first dimension being returned was “Sandboxes”. Any special setting / configuration done for that cube?

Can you also help do a random check on the other cubes if it is doing something like this as well? Had just tried on another TM1 with that version and it was not returning that extra one.


Paul


#7

Hi @plim,

You might be able to reproduce it when you enable the Sandboxes dimension in tm1s.cfg first (EnableSandboxDimension=T).

This parameter is not officially supported until PAL 2.0.4 though, but I am not sure if the behaviour is any different in 2.0.3, I doubt it.


#8

Hi @prajtar,

Thanks for that piece of information! And yes, that was related to that extra dimension being shown now if accessed via REST API.

Hi @tganz,

That would be the root cause for this one.

Can you submit a ticket for this? Thanks!


Paul


#9

Hi @prajtar @plim ,

thanks , setting the EnableSandboxDimension to F , solved the problem.

should I still submit a ticket ?


#10

Hi @tganz,

Yes, please do still.

That could have been a parameter used with PAW for a feature.

Thanks!

Paul


#11

Hi @tganz & @plim,

I am not sure there is a bug? If you turn on EnableSandboxDimension you should provide the sandbox that you want to use in the DBR, cellGet, etc.


#12

Hi @tryan,

It will not really be a bug but more of a scenario that TM1 has introduced and have to be catered to.

Canvas do rely on TM1 to provide a consistent information. On this case however, the change by TM1 to introduce a virtual dimension impacted the way Canvas verifies dimensionality of a cube request.


Paul