Default the Auto Refresh to off

Hi,

Is it possible to default the auto refresh to off when a page opens?

Thanks.

Hi @R.B

not yet, but thats a nice feature to have.

at we can only set it on an application level ,
but cannot override per page/

will add to our list

tnx

How do I set that?

Thanks.

@R.B just to make sure ,
you want to set it to be off-line mode by default for all the views ?

I’m guessing what you are after is improving performance ,
maybe 1 thing you can try before - disable cell annotation and Native Drill on a view level,
and see if that’s looks better ?

Yes, that’s right.

Where do I set that?

Table section of advanced options for grid widget.

"table": {
  "annotations": {
    "enabled": false
  },
  "drill": {
    "enabled": false
  }
}

Hi @tganz ,
I also need this Auto-Refresh default turn off function in the project, but the purpose is not for performance.

We only encountered this problem when using Wizard and checkbox format in the view, the page will keep refreshing continuously. (as pic 1.) Hope these can help.

UX version: 2.5.2.1

pic 1.

Thanks,
Jacky

These are the advanced options to set the Autorefresh:

“toolbar”: {
“realTimeButtonEnabled”: true,
“realTimeEnabled”: true
}

(First one to not give the user the option to toggle autorefresh).

As for your particular issue the issue would be that the grid will try to write back 0 or 1 also for cells that don’t allow data entry since the checkbox is applied for all rows.

Andreas

1 Like

Hi @aalex,
This is really helpful, thank you!

Regards,
Jacky