Decimal separator CANVAS

Hello guys,

I am having problems with Canvas’s decimal place settings, it is not respecting the settings included in the code, as the images below when including “2,2” the final result is “22”, Canvas is not recognizing the comma.
I already made the settings via code and even then the error persists.
If I do the inputs via TM1 directly it works correctly accepting the comma.

I tried several commands like:
tm1-accounting-settings-override = “{currency: {thousand: ‘.’, decimal: ‘,’, precision: ‘3’}}”

I have also tried it on several different browsers and the error is the same.

can you help me?

Thank you


Hi @diegopg8,

To double check, is this still happening after clearing browser cache?

Press <F12> then go to Network, and tick “Disable Cache”. Then press <F5>:


Hello @plim,

I performed the procedure and the problem continues.

I also did the test as you did, I used Canvas Samples, but when entering the values the comma is ignored.

Could we have a problem installing Canvas?

Canvas samples

Canvas samples2

Hi @diegopg8,

On your screenshot, the “Disable cache” is not checked.

Can you try to put a “check” on that?



Sorry, I did the test but I ended up taking the screen print without the flag.
The problem is the same.

Hi @diegopg8,

The underlying issue seems to be related to locales. The value that you have inputted for example, “2,2” is being sent to TM1 as “2.2”. TM1 then recognizes the the locales via a language header and looks like it is interpreting it as “22” - disregarding the dot as decimal separator. This is on the assumption that you are on a locale whose decimal separator is comma and comma separator is the dot.

On Arc or Perspective, are you able to input “2,2” and is it being correctly interpreted?

If it is working alright with Arc/Perspective, can you kindly contact your local Cubewise local office so they can help create and submit a ticket to support?



Performing the tests all work correctly, Perspectives, TM1Web and Architect, only on Canvas that loses formatting.
I’ll check with the support, thanks