Chart formatting with comma separator

Hi all,

It appears that by default Highcharts uses a space as a delimiter instead of a comma when displaying numbers on a chart. To change the global delimiter, typically, one would use “setOptions”. However, I’m not quite sure how to do this in the advanced options window.

lang: {
thousandsSep: ‘,’

I tried adding the lang/thousandsSep lines without setOptions inside “chartOptions” but it doesn’t have any impact. Any suggestions on how to set the global language object before the chart is initialized?



Quick update for anyone else who is trying to get the thousands separators to show as commas, it just requires adding a section of code (i.e., Highcharts.setOptions…) into the required widget js file. In this example, I’ve updated the js file for the map widget (e.g., apq-c3\common\widgets\highmaps\highmaps.js).


After adding the section of code:


@wwang thanks for sharing.

on 2.2 this will not become a global parameter you can set on the default.constants.js file