Cannot see process definition, views in Architect

Hi everyone,
I am unable to see the views I saved, and processes in Architect, after building and saving them in Arc. Although the process is listed under Architect > Processes, but its body is empty. Similarly, I can’t see the Views, that I built and saved in Arc, under Architect > Cube > Views.

Looks like I am missing something very fundamental here. Hopefully someone is able to point me in the right direction.

Thanks
Kaz

Hi @kra5350,

Views built in Arc are MDX views (that support hierarchies) and not the native views you see in Architect. MDX views can only be seen in the newer interfaces like Arc, PAX and PAW. We will plan to add support for native views but they will be limited in functionality because of lack of support for hierarchies and limitations in the REST API.

Processes created and edited in Arc are compatible with Architect. I am not sure what you mean by its body? Post some steps to reproduce and screenshots.

Hi @tryan
Thanks for the prompt reply. The bit about Views make sense, thanks for the explanation.
About the processes, I built a process in Arc, a brand new process, process1. I set the data source to cube view, defined variables, and added some code in Prolog and Data tabs. Saved and closed it.

In Architect, I was able to see process1 listed under Process, but upon opening, data source was set to none, no variables, nothing in prolog and data tabs, except for auto generated code lines.

Thanks
kaz

Hi @kra5350,

Create a ticket at https://support.cubewise.com/code/arc/issues/new with the Bug template filling in all of the details. It is possible it is related to something in the process so attach the pro file as well or it could be a version issue.

image

Hi @tryan,
Thanks for the prompt reply. I will create a ticket.
Thanks
kaz