arc.app 4.3.0 is killed by the Sonoma MacOS

Whenever I start arc.app 4.3.0 on my MacBook Pro running Sonoma 14.3, it is killed by the MacOS.

I have chmod 777 arc.app.

When I upgraded before, I could bypass the MacOS Gatekeeper by clicking Open Anyway button in Privacy & Security settings. Under Security, the “Allow applications downloaded from” is set to “App Store and identified developers.” This setting has been configured by a corporate profile, and disabling it via Terminal command sudo spctl --master-disable is possible, but arc.app is still killed.

Any ideas would be sincerely appreciated.

The same thing is happening to me and the usual recommended process that has worked before (Getting started with Arc Server on Mac - Cubewise CODE) no longer works on Sonoma…

Hello,

I’ve been able to run Arc on Sonoma with the following 2 options.

The prerequisite is to install Rosetta on your Mac if you have a new Apple silicon laptop. If Rosetta is not installed, you’re automatically asked to install it. Rosetta enables a Mac with ARM-based technology to use apps built for a Mac with an x86_64 processor (Intel).

  1. Option 1 (easiest and more secure)
    Go to “Privacy and security>Development tool” to allows Terminal run apps that do not meet the system’s security policy. Start a new terminal session.

  2. Option 2
    Disabling SIP (System Integrity Protection) in recovery mode.

Thank you! #1 worked for me! [I have an Intel processor.]

Thanks @aevanno ! Option 1 works for me, I didn’t need to install Rosetta on an M1-chip, just had to add Terminal to Developer Tools