Apliqo Setup Issue

Hi,

I am trying to setup apliqo in my local computer and using “Apliqo.2021.07.02.exe” for that. The problem is I can not open demo model.

I got no error during the installation. I did put my licence file to the conf folder. When I tried to open apliqo demo, it doesnt work. I checked services, everything accept log on user seems ok. I did changed log on user for “Apliqo Application Server” as “local system”. Then I restarted the related services but it doesnt work again.

So, I checked port 8880 and it seems ok.

Do you have any idea what am I missing?

Regards,

Ali

Can you attach instance.json file?

Did you check the SSL config in TM1 against instance.json restUri parameter?

Hi @acandan

If you’re not seeing the page at all, it could be that there was an issue deploying the web application. If that’s the case, the catalina log in the logs folder where Apliqo is installed should give you an indication of the problem.

You should see something like this:

Also check there is a web application (folder) named Apliqo_Demo within the webapps folder.

George

instances.json (454 Bytes)

This is the instance.json file. I did not changed anything related to SSL config in TM1 side.

catalina.2021-11-08.txt (15.5 KB)

It was a log file i changed it as txt to be able to upload.
SEVERE: The web application [/Apliqo_Demo] appears to have started a thread named [DefaultQuartzScheduler_Worker-1] but has failed to stop it. This is very likely to create a memory leak.
Can this be the cause of the problem?

I do have Apliqo_Demo folder in webapps.

It could be an issue related to the installer @tganz or @cw-ch any ideas?

I also have that error but it’s working for me. I think that error is quite common. Are there any other errors in the log?

Do you get anything different if you try the computer’s IP address instead of localhost?

I see no more error logs and it is the same with computer’s IP.

Might be worth trying an uninstall and reinstall, i’ve just installed the same version and it’s working ok for me

I tried this many times but it didn’t work

@acandan, I see you were looking at the catalina log but do you see anything in the webapp logs? (…/ApliqoServer/webapps/Apliqo_Demo/WEB-INF/logs/application.log) I have seen similar situations were the apliqoas.exe service does not have the necessary access to write to the webapps folder. If you don’t see a recent modify date for the “application.log”, this could be the issue.

There are log records for today. I tried to open demo model then it failed. Next, I check the logs. And there exist log records for that time.

Hi @acandan
There has been an issue with the installer lately where it configures the apliqo aplication server service to run as a user “Local Service” rather than run under “Local System”. Check the Log On tab of the properties of the service. If you see something that looks like the window below then make sure that Local System account is selected. The service should then have permissions to do the operations it needs.

Thanks for the warning, Yes a colleague warned me about this before. I changed it too but it had no effect.

@acandan Have you tried creating another web app to see if you have the same issue there as well? I’m not sure if this is the official way to do but you can copy the apliqo_base folder (available in the root folder of the install) and copy it into the webapps folder then rename as appropriate, just note you’ll need to bring down the service to rename.

I know you said you’ve tried an uninstall and reinstall but have you tried deleting all the folders before the reinstall? As an uninstall doesn’t completely remove all folders. Just make sure you take a backup before if there’s anything you would like to reinstate afterwards.