TM1 Web in Canvas / Application in folder path


#1

If I have a folder path for an application file, how do I reference it?

I tried just the name of the sheet and I also tried the path like so with no luck.

<tm1-ui-web
			tm1-instance="stageFinance"
			tm1-application="Actual/Actual Reports/Profit Rationalization">
</tm1-ui-web>

Thanks,
Chet


#2

Hi Chet,
Did you changed tm1web configuration?

and As I remember you need to use }ApplicationEntries dimension elements. So add ".xlsx" to the end and replace “” with “/”.


#3

Yea, I changed to the below. I also restarted the app service. I am trying to pull a cube view and that does not work either. Seems like a straight forward setup, not sure what I am missing.

<!-- Specify a list of cross domain URL to allow access to TM1Web. 
	If there are more than one url, each is separated by ",". 
	Specify "*" to allow any domain to access TM1Web, good for dev and testing. 
	If not specified, no cross domain access to TM1Web is allowed. -->
<add key="CrossDomainAccessList" value="*" />

<!-- Allows a URL API session to be reused with just an admin host, TM1 server, and (optionally) username -->
<add key="LegacyUrlApiSessionDiscoveryEnabled" value="false" />

#4

use “False”. This parameter key :astonished: sensative.
And, as I mentioned above, use }ApplicationEntries dimension elements. So add “.xlsx” to the end.


#6

really? that’s odd since others are not in it. I will try it out.


#7

I may be wrong but ‘false’ didn’t work for me last time.


#8

we also have a middleware login service that is used for our company apps that is then passed to our cam server. I am removing it form the equation also to see if that might be causing issues.


#9

I missed the xlsx.blob piece in your post. I will try it also. Thanks.


#10

Hi Chet,
I checked the code again. you no need add .blob (or .view) to the end. add only .xlsx

so your tm1-application parameter:
tm1-application=“Applications/Actual/Actual Reports/Profit Rationalization.xlsx”

while your entries element Actual\Actual Reports\Profit Rationalization.xlsx.blob


#11

LegacyUrlApiSessionDiscoveryEnabled configuration parameter
https://www.ibm.com/support/knowledgecenter/en/SS9RXT_10.2.2/com.ibm.swg.ba.cognos.tm1_dg_dvlpr.10.2.2.doc/c_tm1_legacyurlapisessiondiscoveryenabled_config_param.html


#12

Well, I tried the “False”, removing the middleware and changing to the path you recommended.

I think my issue is even logging in through web. Whats odd is that its not even prompting for me to log in like other pages do and just giving 404 errors in console.

Request URL:http:///financechet/api/tokens/stageFinance
Request Method:GET
Status Code:404 Not Found
Remote Address:10.15.46.187:8080
Referrer Policy:no-referrer-when-downgrade

I have tried the /tm1web on the end of the tm1WebUri and without it in the instances.json.

Things in <> i purposely removed.
{
“name”:“stageFinance”,
“restUri”:“http://:8000”,
“tm1WebUri”:“http://:9510”,
“applyParenthesisFormatting”:true,
“chartColorScheme”:["#FB6900", “#F63700”, “#004853”, “#007E80”, “#00B9BD”],
“camNamespaces”:[""]
}

Not sure where to go next. :worried:


#13

did you restart tm1 application server after?
and you might need to restart cubewise application server as well.


#14

Hi @chet_watkins,

Do you mean that you are not even able to login into:

If so, that should be addressed first before anything else.

Then, is your application located at the webapps\ROOT folder or it is on another folder? And is there another server in between that redirects the requests? I noticed that the Request URL is different from the remote URL (port 80 vs 8080).


Paul


#15
  • I can get to the url for tm1web without an issue.
  • Our application is not in ROOT, we have different webapps depending on the server or developer.
  • I am not sure what you mean on the 80 vs 8080, Canvas is running on 8080. TM1Web is 9510.
  • For the instances.json, do i need to have the /tm1web on the url?

#16

Hi @chet_watkins,

The above is the reason why I wanted to check on that. From the URL, the tokens api tthat you are trying to access is at port 80 (URL has no port) -> http:///financechet/api/tokens/stageFinance

Where as the remote address found was: 10.15.46.187:8080

Then regarding the other items:

  1. What is the URL that you are typing to get into tm1web?
  2. What is the folder name? If it is named “finance” for example, then to check the tokens, it should be: http:///financechet/finance/api/tokens/stageFinance
  3. It was because of the token that was posted
  4. Yes you need the tm1web.


Paul


#17

sorry, i might have copy and pasted something wrong.

It is going here.
http://corrdctm02.corp.jabil.org:8080/financechet/api/tokens/stageFinance

and returning this when i go to the url.
{“statusCode”:404,“success”:false,“failed”:true,“message”:“No token found for instance - stageFinance”,“error”:{“message”:“No token found for instance - stageFinance”}}

my instances.json

[
{
“name”:“stageFinance”,
“restUri”:“http://corrdcctmstg10.corp.jabil.org:8000”,
“tm1WebUri”:“http://usstpc0web01.corp.jabil.org:9510/tm1web/”,
“applyParenthesisFormatting”:true,
“chartColorScheme”:["#FB6900", “#F63700”, “#004853”, “#007E80”, “#00B9BD”],
“camNamespaces”:[“Jabil_AD”]
}
]


#18

Hi @chet_watkins,

Try this out:

  1. Logout of your Canvas application
  2. Open Developer Console
  3. Go to a page on your application where you will need to login
  4. Clear all network requests (to make it easier to spot network errors)
  5. Login to Canvas

On the developer console, any errors that you see in there? This should give a clue as to whether it was able to authenticate properly with tm1web.


Paul


#19

If I go to a page that just has a tm1web component on it, it never asks me to authenticate. It just hits the below message twice and then brings up the error message for the tm1web component.

Request URL:http://corrdctm02.corp.jabil.org:8080/financechet/api/tokens/stageFinance
Request Method:GET
Status Code:404 Not Found
Remote Address:10.15.46.187:8080
Referrer Policy:no-referrer-when-downgrade


#20

You can ignore that last update. I am now under the belief it should be working, but the chrome plug in our IT department uses is blocking it. Will work with them on the issue. Thanks for all the help.