Source Code repository not working for a new server


#1

Hi,

I set up a new DEV server as a copy of a server that’d been monitored by Pulse. I didn’t make any changes to Pulse configuration but I checked that the new server was immediately discovered and monitored by Pulse. I made some changes on the DEV server and wanted to migrate them to production. However, when I tried to browse the Source Code repository, it was empty for the new server. I restarted Pulse, TM1 servers and filled in the admin credentials for both servers in Pulse configuration. Eventually I was able to see only the files I modified on the DEV server, but not the entire repository:

Can you advise what I can do to enable the full source code repository?


#2

HI @prajtar

Have you tried to update the documentation?

Cheers,


#3

Hi Vincent,

This is what I am getting after 5 seconds:


#4

What is your TM1 version and Pulse version?

The different reasons why Pulse is not able to run the update documentations are:

  1. User name and password are wrong in Pulse Instance settings
  2. Cam namespace is wrong in Pulse instance settings (Cam namespace is case sensitive)
  3. When a new TM1 instance is created: restart Pulse services (Pulse will add }src TM1 processes to the TM1 instance) and then you will have to restart the TM1 instance for TM1 to pick up these new TM1 processes.
  4. SSL issue, you are using an old version of Pulse with new SSL certificates, you should upgrade to the latest version v5.5.1.

#5

Thanks Vincent, it was reason no. 3 for me - restarting the TM1 instance solved the issue.