Replacing home.html

canvas

#1

Hi all,

We have a request to have the home page automatically referenced one of the dashboard that we have built for them.

However, it is not possible to define a home page within Canvas, so we consulted Paul and got a workaround by replacing the dashboard.html to home.html, and everything should just work. (But this was from the previous version of Canvas)

Now we have upgraded to the latest version of Canvas, this trick seems not working anymore, it’s always redirecting to sample-home, tried to do F12 trace, nothing valuable returned.

We have already tried the following:

  1. Restart Canvas.
  2. InPrivate Browsing.
  3. Clear cache
  4. Use another machine.

Any help would be appreciated.

Thanks

Tat


#2

In the home controller, put $state.go(‘stateName’);
where stateName is the state of your dashboard.


#3

Using this would make Canvas super unstable, return {HOME|Error} always 60% of the chance.

And this is why Paul gave me that workaround previously.


#4

Hi @twong,

What is the URL that you are using to test this out? Or what is the name of the folder from which you are testing this?

That normally is the case if you are using the samples folder/application.


Paul


#5

Hi Paul,

URL: http://twtpewapmap2u.hq.intra.client.com:8080/apms/
Folder: D:\Program Files\CWAS\webapps\apms\html

I don’t think I am on sample folder, but let me know if I am in the wrong place.

Tat


#6

Hi @twong,

Am I correct to say that what you have done is replace home.html with the contents of dashboard.html?

Or did you remove the home.html and replaced it with dashboard.html?


Paul


#7

Hi Paul,

Both correct!

What I did is renamed home.html to home_old.html, and rename dashboard.html to home.html.

Will that cause problem?

Regards

Tat


#8

Hi @twong,

That should be just alright. have you checked the WEB-INF/config/settings.json? That is where you will find that setting about demo. Could you check and verify what is the value in there? If it is true, change it to false for now and restart the server afterwards.

Let us know how it is now.


Paul


#9

Hi @twong,

Why would that make it unstable?


#10

No idea, it just keep giving me that error.

@plim, do you remember what’s the cause?

I think it is something to do with SSO, Paul assisted to debug it, and then he suggested to use the replacing home.html instead.