Pulse - PA TM1Web logging

Is pulse version 5.7.10 compatible with TM1 version - PA_2.0.6 + PA_2.0.6_IF3 ?
I cannot see tm1 web usage details on pulse. I followed the steps given on https://code.cubewise.com/docs/enable-tm1-web-logging-to-pulse but no success.

Hi @jharshad,

Yes the TM1Web logging should work.

Is TM1 Web installed on the same server as the TM1 server or is it on a separate server? If TM1 web is on a separate there are some manual steps that you have to do to insert the pulse script to the TM1 Web folder.

Cheers,

Vincent

TM1 web is installed on separate server and i have already done the manual steps but still not working.We are not using SSL but still i did the steps 7,8 & 9 (given below). Is that an issue ?

  1. If you are using SSL on the Pulse server (this is NOT on by default) change the pulseSSL to true, you will also need to change the port number. The default SSL port number is 8093 .
  2. If you have change the web port for Pulse from the default 8099 you need to enter your port number in the pulsePortNo setting.
  3. Save the pulseLog.jsp page, you may need to save it to the Desktop and then copy the file to the directory due to Windows UAC restrictions

Hi @jharshad,

Yes you should not do these extra steps if you are not using SSL.

Maybe the port number that Pulse uses might be block on the TM1 Web server, you could check if you can access Pulse from the TM1 Web server, to do that just type the Pulse URL in a browser inside the TM1 web server.

@Vincent - Please let me know which steps (in number) from that script do I need to skip ?

Hi @jharshad,

The steps to setup the TM1 Web logging are explained in this article: https://code.cubewise.com/docs/enable-tm1-web-logging-to-pulse

You just need to make sure you follow the steps in the IBM Planning Analytics section.

If you are not using SSL, then you should skip step 7:
“If you are using SSL on the Pulse server (this is NOT on by default) change the pulseSSL to true, you will also need to change the port number. The default SSL port number is 8093 .”

If you are using the default Pulse port number 8099, you should skip step 8:
“If you have change the web port for Pulse from the default 8099 you need to enter your port number in the pulsePortNo setting.”

If you still can’t make it work, please reach out to your Cubewise local office, setting up TM1 Web logging when TM1 Web is on a separate server is a common requirement, they will find someone to help you.

I hope this help,

Cheers,

Vincent

Hi I have a related question. We are investigating a problem where calls from PulseLog.jsp are getting into pending states affecting tm1web perfromance.
If I want to stop them temporarily (at the moment we have to switch off Pulse completely and they nee it)
What would be the best way to do it. I would like the answer urgently as I want to go and make the changes this Friday.
I could reverse all the changes here: https://code.cubewise.com/docs/enable-tm1-web-logging-to-pulse but hopefully we will fix the underlying issue and we will be re-enabling it soon…

Hi @pgrochola,

You should remove the pulse.js script tag from home.jsp and application.jsp.