Failed to update UX from 2020.08.beta to 2020.08

Hi,

When I tried to update UX from 2020.08.beta to 2020.08, the TI (}APQ.UX.Server.Upgrade) popup an error message.

What I did,

  1. Stop the content store
  2. Copy/Paste the offline-package 2020.08 Offline Loose File Package to data folder
  3. Start the content store
  4. Executed the TI (}APQ.UX.Server.Upgrade)
  5. then got the message

Can someone help me to resolve this?

Thanks,

Ronan

Hi @rwang

This would be becasue you used the loose file upgrade so the new measure is refered to in the rule but not present in the measure dimension until after the upgrade process is run.

Just run the upgrade process again. There should be no error the 2nd time.

Hi @cw-ch,

Thanks for your reply.
I have tried to execute the TI twice, but not worked.

But I added two elements (EncapsulatedPassword, PasswordError) into }APQ UX Instance Client Measure, then the TI works.

Hi @rwang
How did you do the upgrade? Becasue I checked the upgrade process and it definately takes care of making sure these elements exist …


If you are not using Pulse then the new upgrade process must always be run FIRST before any of the updated rux files are added to the directory. Only after the upgrade process has been run to ensure that all the dimension metadata updates are done should the rest of the rux and pro files be updated.

Not sure if you fixed it already @rwang but you need to clear the rule of }APQ UX Instance Client, run the APQ Server Update process which will also add the missing element. Copy back the rule.

This solved my issue.